Skip to content

Installation

Download Pre-built Binaries

Latest Stable

https://github.com/genet-app/genet/releases

Windows

You need WinPcap to run live capture.

See Also: https://www.winpcap.org/install/

Linux

AppImage binary does not support live capture.

Nightly

https://console.cloud.google.com/storage/genet-app-nightly

You need a Google account to browse nightly builds.

Only macOS and Linux builds are available.

Optional Dependencies

npm

You need npm to install a 3rd-party package depends on other npm packages.

See Also: https://www.npmjs.com/get-npm

Rust Toolchain

You need rust toolchains to install a 3rd-party package written in Rust.

See Also: https://www.rustup.rs/

gpm

gpm (genet pacakge manager) is a command line tool to manage 3rd-party packages.

Installation

You need Node.js >= 8.x to run gpm.

1
2
3
npm install --global @genet/gpm
# or
yarn global add @genet/gpm