Skip to content

Rust SDK

Documentation: https://docs.rs/genet-sdk

Current Version

Add genet-sdk crate as a dependency.

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
[package]
name = "eth"
version = "1.0.0"

[lib]
name = "main"
crate-type = ["cdylib"]

[dependencies]
genet-sdk = "^0.1.0"

About genet-sdk version

Basically, genet respects a version of genet-sdk in Cargo.toml as long as the major version matches the host program.

When the major version is incompatible or indeterminate (e.g. genet-sdk = '*'), sdk verison could be replaced to satisfy the requirements before build process.